about summary refs log tree commit diff
path: root/users/glittershark/system/system/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/system/default.nix')
-rw-r--r--users/glittershark/system/system/default.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/users/glittershark/system/system/default.nix b/users/glittershark/system/system/default.nix
index a9eb4a130a..174ccfb360 100644
--- a/users/glittershark/system/system/default.nix
+++ b/users/glittershark/system/system/default.nix
@@ -16,7 +16,13 @@ rec {
   yeren = import ./machines/yeren.nix;
 
   yerenSystem = (pkgs.nixos {
-    configuration = yeren;
+    configuration = { ... }: {
+      imports = [
+        ./machines/yeren.nix
+        "${depot.depotPath}/ops/nixos/depot.nix"
+      ];
+      inherit depot;
+    };
   }).system;
 
   iso = import ./iso.nix args;