about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/clang-tools/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/pkgs/clang-tools/default.nix')
-rw-r--r--users/glittershark/system/pkgs/clang-tools/default.nix24
1 files changed, 0 insertions, 24 deletions
diff --git a/users/glittershark/system/pkgs/clang-tools/default.nix b/users/glittershark/system/pkgs/clang-tools/default.nix
deleted file mode 100644
index 7c1009665e..0000000000
--- a/users/glittershark/system/pkgs/clang-tools/default.nix
+++ /dev/null
@@ -1,24 +0,0 @@
-{ pkgs }:
-with pkgs;
-
-runCommand "clang-tools" {} ''
-  mkdir -p $out/bin
-  export libc_includes="${stdenv.lib.getDev stdenv.cc.libc}/include"
-  export libcpp_includes="${llvmPackages.libcxx}/include/c++/v1"
-
-  export clang=${llvmPackages.clang-unwrapped}
-
-  echo $clang
-
-  substituteAll ${./wrapper} $out/bin/clangd
-  chmod +x $out/bin/clangd
-  for tool in \
-    clang-apply-replacements \
-    clang-check \
-    clang-format \
-    clang-rename \
-    clang-tidy
-  do
-    ln -s $out/bin/clangd $out/bin/$tool
-  done
-''