about summary refs log tree commit diff
path: root/users/glittershark/system/pkgs/clang-tools/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/pkgs/clang-tools/default.nix')
-rw-r--r--users/glittershark/system/pkgs/clang-tools/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/users/glittershark/system/pkgs/clang-tools/default.nix b/users/glittershark/system/pkgs/clang-tools/default.nix
new file mode 100644
index 0000000000..7c1009665e
--- /dev/null
+++ b/users/glittershark/system/pkgs/clang-tools/default.nix
@@ -0,0 +1,24 @@
+{ pkgs }:
+with pkgs;
+
+runCommand "clang-tools" {} ''
+  mkdir -p $out/bin
+  export libc_includes="${stdenv.lib.getDev stdenv.cc.libc}/include"
+  export libcpp_includes="${llvmPackages.libcxx}/include/c++/v1"
+
+  export clang=${llvmPackages.clang-unwrapped}
+
+  echo $clang
+
+  substituteAll ${./wrapper} $out/bin/clangd
+  chmod +x $out/bin/clangd
+  for tool in \
+    clang-apply-replacements \
+    clang-check \
+    clang-format \
+    clang-rename \
+    clang-tidy
+  do
+    ln -s $out/bin/clangd $out/bin/$tool
+  done
+''