about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/email.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/email.nix')
-rw-r--r--users/glittershark/system/home/modules/email.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/users/glittershark/system/home/modules/email.nix b/users/glittershark/system/home/modules/email.nix
index 62c8be19a2..48d6b5f3cc 100644
--- a/users/glittershark/system/home/modules/email.nix
+++ b/users/glittershark/system/home/modules/email.nix
@@ -36,26 +36,26 @@ in {
     msmtp
   ];
 
-  nixpkgs.overlays = [(self: super: {
-    notifymuch = self.python3Packages.callPackage ../../pkgs/notifymuch.nix {};
-  })];
+  # nixpkgs.overlays = [(self: super: {
+  #   notifymuch = self.python3Packages.callPackage ../../pkgs/notifymuch.nix {};
+  # })];
 
   systemd.user.services = mapAttrs' (name: account: {
     name = escapeUnitName "lieer-${name}";
     value.Service.ExecStart = mkForce "${pkgs.writeShellScript "sync-${name}" ''
       ${pkgs.gmailieer}/bin/gmi sync
-      ${pkgs.notifymuch}/bin/notifymuch
     ''}";
+    # ${pkgs.notifymuch}/bin/notifymuch
   }) accounts;
 
-  xdg.configFile."notifymuch/notifymuch.cfg".text = generators.toINI {} {
-    notifymuch = {
-      query = "is:unread and is:important";
-      mail_client = "";
-      recency_interval_hours = "48";
-      hidden_tags = "inbox unread attachment replied sent encrypted signed";
-    };
-  };
+  # xdg.configFile."notifymuch/notifymuch.cfg".text = generators.toINI {} {
+  #   notifymuch = {
+  #     query = "is:unread and is:important";
+  #     mail_client = "";
+  #     recency_interval_hours = "48";
+  #     hidden_tags = "inbox unread attachment replied sent encrypted signed";
+  #   };
+  # };
 
   accounts.email.maildirBasePath = "mail";
   accounts.email.accounts = mapAttrs (_: params@{ passEntry, ... }: {