about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/development/rust.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/development/rust.nix')
-rw-r--r--users/glittershark/system/home/modules/development/rust.nix25
1 files changed, 0 insertions, 25 deletions
diff --git a/users/glittershark/system/home/modules/development/rust.nix b/users/glittershark/system/home/modules/development/rust.nix
deleted file mode 100644
index 4deb83465289..000000000000
--- a/users/glittershark/system/home/modules/development/rust.nix
+++ /dev/null
@@ -1,25 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-
-{
-  home.packages = with pkgs; [
-    rustup
-    rust-analyzer
-    cargo-edit
-    cargo-expand
-    sccache
-  ];
-
-  programs.zsh.shellAliases = {
-    "cg" = "cargo";
-    "cb" = "cargo build";
-    "ct" = "cargo test";
-    "ctw" = "fd -e rs | entr cargo test";
-    "cch" = "cargo check";
-  };
-
-  home.file.".cargo/config".text = ''
-    [build]
-    rustc-wrapper = "${pkgs.sccache}/bin/sccache"
-  '';
-}