about summary refs log tree commit diff
path: root/users/glittershark/system/home/modules/common.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/modules/common.nix')
-rw-r--r--users/glittershark/system/home/modules/common.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/users/glittershark/system/home/modules/common.nix b/users/glittershark/system/home/modules/common.nix
new file mode 100644
index 0000000000..ed7a729a79
--- /dev/null
+++ b/users/glittershark/system/home/modules/common.nix
@@ -0,0 +1,49 @@
+{ config, lib, pkgs, ... }:
+
+# Everything in here needs to work on linux or darwin
+
+{
+  imports = [
+    ../modules/shell.nix
+    ../modules/development.nix
+    ../modules/emacs.nix
+    ../modules/vim.nix
+    ../modules/tarsnap.nix
+    ../modules/twitter.nix
+    ../modules/lib/cloneRepo.nix
+  ];
+
+  nixpkgs.config.allowUnfree = true;
+
+  programs.password-store.enable = true;
+
+  grfn.impure.clonedRepos.passwordStore = {
+    github = "glittershark/pass";
+    path = ".local/share/password-store";
+  };
+
+  urbint.projectPath = "code/urb";
+
+  home.packages = with pkgs; [
+    # System utilities
+    bat
+    htop
+    killall
+    bind
+    zip unzip
+    tree
+    ncat
+    bc
+
+    # Security
+    gnupg
+    keybase
+    openssl
+
+    # Nix things
+    nixfmt
+    nix-prefetch-github
+    nix-review
+    cachix
+  ];
+}