about summary refs log tree commit diff
path: root/users/glittershark/system/home/machines/roswell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/machines/roswell.nix')
-rw-r--r--users/glittershark/system/home/machines/roswell.nix57
1 files changed, 0 insertions, 57 deletions
diff --git a/users/glittershark/system/home/machines/roswell.nix b/users/glittershark/system/home/machines/roswell.nix
deleted file mode 100644
index 1b1bbf29c616..000000000000
--- a/users/glittershark/system/home/machines/roswell.nix
+++ /dev/null
@@ -1,57 +0,0 @@
-{ pkgs, lib, config, ... }:
-
-let
-  laptopKeyboardId = "5";
-in
-
-{
-  imports = [
-    ../platforms/linux.nix
-    ../modules/shell.nix
-    ../modules/development.nix
-    ../modules/emacs.nix
-    ../modules/vim.nix
-  ];
-
-  home.packages = with pkgs; [
-    # System utilities
-    bat
-    htop
-    killall
-    bind
-    zip unzip
-    tree
-    ncat
-    bc
-    pv
-
-    # Security
-    gnupg
-    keybase
-    openssl
-
-    # Nix things
-    nixfmt
-    nix-prefetch-github
-    nix-review
-    cachix
-  ];
-
-
-  nixpkgs.config.allowUnfree = true;
-
-  programs.password-store.enable = true;
-
-  programs.home-manager.enable = true;
-  home.stateVersion = "20.03";
-
-  xsession.enable = lib.mkForce false;
-
-  services.lorri.enable = true;
-
-  programs.direnv = {
-    enable = true;
-    enableBashIntegration = true;
-    enableZshIntegration = true;
-  };
-}