about summary refs log tree commit diff
path: root/users/glittershark/system/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/system/home/default.nix')
-rw-r--r--users/glittershark/system/home/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/glittershark/system/home/default.nix b/users/glittershark/system/home/default.nix
new file mode 100644
index 000000000000..1d6d8795ab97
--- /dev/null
+++ b/users/glittershark/system/home/default.nix
@@ -0,0 +1,36 @@
+{ pkgs, depot, lib, ... }:
+
+with lib;
+
+rec {
+  nixpkgs = import pkgs.nixpkgsSrc {};
+
+  home = confPath: (import "${nixpkgs.home-manager.src}/modules" {
+    pkgs = nixpkgs;
+    configuration = { config, lib, ... }: {
+      imports = [confPath];
+
+      _module.args.pkgs = mkForce
+        (import pkgs.nixpkgsSrc (filterAttrs (n: v: v != null) config.nixpkgs));
+
+      lib.depot = depot;
+    };
+  });
+
+  chupacabra = home ./machines/chupacabra.nix;
+
+  chupacabraHome = chupacabra.activation-script;
+
+  dobharchu = home ./machines/dobharchu.nix;
+
+  dobharchuHome = dobharchu.activation-script;
+
+  yeren = home ./machines/yeren.nix;
+
+  yerenHome = yeren.activation-script;
+
+  meta.targets = [
+    "chupacabraHome"
+    "yerenHome"
+  ];
+}