about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/gws.fyi/default.nix')
-rw-r--r--users/glittershark/gws.fyi/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/users/glittershark/gws.fyi/default.nix b/users/glittershark/gws.fyi/default.nix
new file mode 100644
index 000000000000..6ec1262f67be
--- /dev/null
+++ b/users/glittershark/gws.fyi/default.nix
@@ -0,0 +1,21 @@
+args@{ pkgs, ... }:
+with pkgs;
+let
+  site = import ./site.nix args;
+  resume = import ../resume args;
+  bucket = "s3://gws.fyi";
+  distributionID = "E2ST43JNBH8C64";
+  website =
+    runCommand "gws.fyi" { } ''
+      mkdir -p $out
+      cp ${site.index} $out/index.html
+      cp ${resume} $out/resume.pdf
+    '';
+
+in writeShellScript "deploy.sh" ''
+  ${awscli}/bin/aws s3 sync ${website}/ ${bucket}
+  ${awscli}/bin/aws cloudfront create-invalidation \
+    --distribution-id "${distributionID}" \
+    --paths "/*"
+  echo "Deployed to http://gws.fyi"
+''