about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/gws.fyi/default.nix')
-rw-r--r--users/glittershark/gws.fyi/default.nix31
1 files changed, 0 insertions, 31 deletions
diff --git a/users/glittershark/gws.fyi/default.nix b/users/glittershark/gws.fyi/default.nix
deleted file mode 100644
index ef3ef6c57080..000000000000
--- a/users/glittershark/gws.fyi/default.nix
+++ /dev/null
@@ -1,31 +0,0 @@
-args@{ pkgs, ... }:
-with pkgs;
-let
-  site = import ./site.nix args;
-  resume = import ../resume args;
-  bucket = "s3://gws.fyi";
-  distributionID = "E2ST43JNBH8C64";
-
-  css = runCommand "main.css" {
-    buildInputs = [ pkgs.minify ];
-  } ''
-    minify --type css < ${./main.css} > $out
-  '';
-
-  website =
-    runCommand "gws.fyi" { } ''
-      mkdir -p $out
-      cp ${css} $out/main.css
-      cp ${site.index} $out/index.html
-      cp ${resume} $out/resume.pdf
-    '';
-
-in (writeShellScript "deploy.sh" ''
-  ${awscli}/bin/aws --profile personal s3 sync ${website}/ ${bucket}
-  ${awscli}/bin/aws --profile personal cloudfront create-invalidation \
-    --distribution-id "${distributionID}" \
-    --paths "/*"
-  echo "Deployed to http://gws.fyi"
-'') // {
-  inherit website;
-}