about summary refs log tree commit diff
path: root/users/glittershark/gws.fyi/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/glittershark/gws.fyi/default.nix')
-rw-r--r--users/glittershark/gws.fyi/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/glittershark/gws.fyi/default.nix b/users/glittershark/gws.fyi/default.nix
new file mode 100644
index 0000000000..6cf7c977e6
--- /dev/null
+++ b/users/glittershark/gws.fyi/default.nix
@@ -0,0 +1,16 @@
+with import <nixpkgs> {};
+let
+  bucket = "s3://gws.fyi";
+  distributionID = "E2ST43JNBH8C64";
+  website =
+    runCommand "gws.fyi" { } ''
+      mkdir -p $out
+      cp ${./index.html} $out/index.html
+    '';
+in writeShellScript "deploy.sh" ''
+  ${awscli}/bin/aws s3 sync ${website}/ ${bucket}
+  ${awscli}/bin/aws cloudfront create-invalidation \
+    --distribution-id "${distributionID}" \
+    --paths "/*"
+  echo "Deployed to http://gws.fyi"
+''