about summary refs log tree commit diff
path: root/users/aspen/system/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/aspen/system/home/default.nix')
-rw-r--r--users/aspen/system/home/default.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/users/aspen/system/home/default.nix b/users/aspen/system/home/default.nix
new file mode 100644
index 0000000000..f821999b99
--- /dev/null
+++ b/users/aspen/system/home/default.nix
@@ -0,0 +1,36 @@
+{ pkgs, depot, lib, ... }:
+
+with lib;
+
+rec {
+  home = confPath: (import (pkgs.home-manager.src + "/modules") {
+    inherit pkgs;
+
+    configuration = { config, lib, ... }: {
+      imports = [ confPath ];
+      lib.depot = depot;
+
+      # home-manager exposes no API to override the package set that
+      # is used, unless called from the NixOS module.
+      #
+      # To get around it, the module argument is overridden here.
+      _module.args.pkgs = mkForce pkgs;
+    };
+  });
+
+  dobharchu = home ./machines/dobharchu.nix;
+
+  dobharchuHome = dobharchu.activation-script;
+
+  ogopogo = home ./machines/ogopogo.nix;
+
+  ogopogoHome = ogopogo.activation-script;
+
+  yeren = home ./machines/yeren.nix;
+
+  yerenHome = yeren.activation-script;
+
+  meta.ci.targets = [
+    "yerenHome"
+  ];
+}