about summary refs log tree commit diff
path: root/users/Profpatsch/ytextr/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/ytextr/default.nix')
-rw-r--r--users/Profpatsch/ytextr/default.nix91
1 files changed, 57 insertions, 34 deletions
diff --git a/users/Profpatsch/ytextr/default.nix b/users/Profpatsch/ytextr/default.nix
index dba6bbb8b4..ac630603b9 100644
--- a/users/Profpatsch/ytextr/default.nix
+++ b/users/Profpatsch/ytextr/default.nix
@@ -12,48 +12,71 @@
 
 let
   bins = depot.nix.getBins pkgs.nix [ "nix-build" ]
-      // depot.nix.getBins pkgs.bubblewrap [ "bwrap" ];
+    // depot.nix.getBins pkgs.bubblewrap [ "bwrap" ];
 
   # Run a command, with the given packages in scope, and `packageNamesAtRuntime` being fetched at the start in the given nix `channel`.
-  nix-run-with-channel = {
-    # The channel to get `packageNamesAtRuntime` from
-    channel,
-    # executable to run with `packageNamesAtRuntime` in PATH
-    # and the argv
-    executable,
-    # A list of nixpkgs package attribute names that should be put into PATH when running `command`.
-    packageNamesAtRuntime,
-  }: depot.nix.writeExecline "nix-run-with-channel-${channel}" {} [
-    # TODO: prevent race condition by writing a temporary gc root
-    "backtick" "-iE" "storepath" [
-      bins.nix-build
-        "-I" "nixpkgs=channel:${channel}"
+  nix-run-with-channel =
+    {
+      # The channel to get `packageNamesAtRuntime` from
+      channel
+    , # executable to run with `packageNamesAtRuntime` in PATH
+      # and the argv
+      executable
+    , # A list of nixpkgs package attribute names that should be put into PATH when running `command`.
+      packageNamesAtRuntime
+    ,
+    }: depot.nix.writeExecline "nix-run-with-channel-${channel}" { } [
+      # TODO: prevent race condition by writing a temporary gc root
+      "backtick"
+      "-iE"
+      "storepath"
+      [
+        bins.nix-build
+        "-I"
+        "nixpkgs=channel:${channel}"
         "--arg"
-          "packageNamesAtRuntimeJsonPath"
-          (pkgs.writeText "packageNamesAtRuntime.json" (builtins.toJSON packageNamesAtRuntime))
+        "packageNamesAtRuntimeJsonPath"
+        (pkgs.writeText "packageNamesAtRuntime.json" (builtins.toJSON packageNamesAtRuntime))
         ./create-symlink-farm.nix
-    ]
-    "importas" "-ui" "PATH" "PATH"
-    "export" "PATH" "\${storepath}/bin:\${PATH}"
-    executable "$@"
-  ];
+      ]
+      "importas"
+      "-ui"
+      "PATH"
+      "PATH"
+      "export"
+      "PATH"
+      "\${storepath}/bin:\${PATH}"
+      executable
+      "$@"
+    ];
 
-in nix-run-with-channel {
+in
+nix-run-with-channel {
   channel = "nixos-unstable";
   packageNamesAtRuntime = [ "yt-dlp" ];
   executable = depot.nix.writeExecline "ytextr" { readNArgs = 1; } [
-    "getcwd" "-E" "cwd"
+    "getcwd"
+    "-E"
+    "cwd"
     bins.bwrap
-      "--ro-bind" "/nix/store" "/nix/store"
-      "--ro-bind" "/etc" "/etc"
-      "--bind" "$cwd" "$cwd"
-        "yt-dlp"
-        "--no-playlist"
-        "--write-sub"
-        "--all-subs"
-        "--embed-subs"
-        "--merge-output-format" "mkv"
-        "-f" "bestvideo[height<=?1080]+bestaudio/best"
-        "$1"
+    "--ro-bind"
+    "/nix/store"
+    "/nix/store"
+    "--ro-bind"
+    "/etc"
+    "/etc"
+    "--bind"
+    "$cwd"
+    "$cwd"
+    "yt-dlp"
+    "--no-playlist"
+    "--write-sub"
+    "--all-subs"
+    "--embed-subs"
+    "--merge-output-format"
+    "mkv"
+    "-f"
+    "bestvideo[height<=?1080]+bestaudio/best"
+    "$1"
   ];
 }