about summary refs log tree commit diff
path: root/users/Profpatsch/writers/tests/default.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--users/Profpatsch/writers/tests/default.nix (renamed from users/Profpatsch/writers/tests.nix)19
1 files changed, 16 insertions, 3 deletions
diff --git a/users/Profpatsch/writers/tests.nix b/users/Profpatsch/writers/tests/default.nix
index 680c37a2ec02..a16f5fa1f972 100644
--- a/users/Profpatsch/writers/tests.nix
+++ b/users/Profpatsch/writers/tests/default.nix
@@ -1,10 +1,23 @@
-{ depot, pkgs, python3, python3Lib, rustSimpleLib, rustSimple, testRustSimple }:
+{ depot, ... }:
 
 let
+  inherit (depot.users.Profpatsch.writers)
+    python3Lib
+    python3
+    testRustSimple
+    rustSimple
+    rustSimpleLib
+    rustSimpleBin
+    ;
+
+  inherit (depot.third_party)
+    coreutils
+    ;
+
   run = drv: depot.nix.runExecline.local "run-${drv.name}" {} [
     "if" [ drv ]
     "importas" "out" "out"
-    "${pkgs.coreutils}/bin/touch" "$out"
+    "${coreutils}/bin/touch" "$out"
   ];
 
   pythonTransitiveLib = python3Lib {
@@ -76,7 +89,7 @@ let
   '');
 
 
-in {
+in depot.nix.utils.drvTargets {
   inherit
     pythonWithLib
     rustTransitiveLib