about summary refs log tree commit diff
path: root/users/Profpatsch/writers/tests.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/writers/tests.nix')
-rw-r--r--users/Profpatsch/writers/tests.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/users/Profpatsch/writers/tests.nix b/users/Profpatsch/writers/tests.nix
new file mode 100644
index 0000000000..4cae230e0e
--- /dev/null
+++ b/users/Profpatsch/writers/tests.nix
@@ -0,0 +1,22 @@
+{ depot, pkgs, python3Lib }:
+
+let
+  testLib = python3Lib {
+    name = "test_lib";
+  } ''
+    def test():
+      return "test"
+  '';
+
+  pythonWithLib = pkgs.writers.writePython3 "python-with-lib" {
+    libraries = [ testLib ];
+  } ''
+    import test_lib
+
+    assert(test_lib.test() == "test")
+  '';
+
+in {
+  inherit
+    pythonWithLib;
+}