about summary refs log tree commit diff
path: root/users/Profpatsch/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/shell.nix')
-rw-r--r--users/Profpatsch/shell.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/users/Profpatsch/shell.nix b/users/Profpatsch/shell.nix
index 3420bcdb0ace..640be96cd0ef 100644
--- a/users/Profpatsch/shell.nix
+++ b/users/Profpatsch/shell.nix
@@ -12,14 +12,21 @@ pkgs.mkShell {
     (pkgs.haskellPackages.ghcWithHoogle (h: [
       h.async
       h.aeson-better-errors
+      h.blaze-html
       h.conduit-extra
       h.error
+      h.monad-logger
+      h.pa-field-parser
+      h.pa-label
+      h.ihp-hsx
       h.PyF
       h.unliftio
       h.wai
+      h.wai-extra
       h.warp
       h.profunctors
       h.semigroupoids
+      h.servant-multipart
       h.validation-selective
       h.free
       h.cryptonite-conduit
@@ -40,7 +47,6 @@ pkgs.mkShell {
       depot.users.Profpatsch.netencode.netencode-hs
       depot.users.Profpatsch.arglib.netencode.haskell
       depot.users.Profpatsch.execline.exec-helpers-hs
-
     ]))
 
     pkgs.rustup