about summary refs log tree commit diff
path: root/users/Profpatsch/read-http/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/read-http/default.nix')
-rw-r--r--users/Profpatsch/read-http/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/users/Profpatsch/read-http/default.nix b/users/Profpatsch/read-http/default.nix
new file mode 100644
index 0000000000..20f8675b3f
--- /dev/null
+++ b/users/Profpatsch/read-http/default.nix
@@ -0,0 +1,19 @@
+{ depot, pkgs, ... }:
+
+let
+
+  # reads a http request (stdin), and writes all headers to stdout, as netencoded dict
+  read-http = depot.users.Profpatsch.writers.rustSimple {
+    name = "read-http";
+    dependencies = [
+      depot.users.Profpatsch.rust-crates.httparse
+      depot.users.Profpatsch.netencode.netencode-rs
+      depot.users.Profpatsch.arglib.netencode.rust
+    ];
+  } (builtins.readFile ./read-http.rs);
+
+in {
+  inherit
+    read-http
+    ;
+}