about summary refs log tree commit diff
path: root/users/Profpatsch/netstring/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/netstring/default.nix')
-rw-r--r--users/Profpatsch/netstring/default.nix19
1 files changed, 11 insertions, 8 deletions
diff --git a/users/Profpatsch/netstring/default.nix b/users/Profpatsch/netstring/default.nix
index b4990cae67..e85cf24dd8 100644
--- a/users/Profpatsch/netstring/default.nix
+++ b/users/Profpatsch/netstring/default.nix
@@ -12,9 +12,10 @@ let
         (k: v: toNetstring (toNetstring k + toNetstring v))
         attrs);
 
-  python-netstring = depot.users.Profpatsch.writers.python3Lib {
-    name = "netstring";
-  } ''
+  python-netstring = depot.users.Profpatsch.writers.python3Lib
+    {
+      name = "netstring";
+    } ''
     def read_netstring(bytes):
         (int_length, rest) = bytes.split(sep=b':', maxsplit=1)
         val = rest[:int(int_length)]
@@ -39,9 +40,10 @@ let
         return res
   '';
 
-  rust-netstring = depot.nix.writers.rustSimpleLib {
-    name = "netstring";
-  } ''
+  rust-netstring = depot.nix.writers.rustSimpleLib
+    {
+      name = "netstring";
+    } ''
     pub fn to_netstring(s: &[u8]) -> Vec<u8> {
         let len = s.len();
         // length of the integer as ascii
@@ -55,12 +57,13 @@ let
     }
   '';
 
-in depot.nix.readTree.drvTargets {
+in
+depot.nix.readTree.drvTargets {
   inherit
     toNetstring
     toNetstringList
     toNetstringKeyVal
     python-netstring
     rust-netstring
-      ;
+    ;
 }