about summary refs log tree commit diff
path: root/users/Profpatsch/mailbox-org/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/mailbox-org/default.nix')
-rw-r--r--users/Profpatsch/mailbox-org/default.nix44
1 files changed, 26 insertions, 18 deletions
diff --git a/users/Profpatsch/mailbox-org/default.nix b/users/Profpatsch/mailbox-org/default.nix
index 99b9d45b7d..cd41904722 100644
--- a/users/Profpatsch/mailbox-org/default.nix
+++ b/users/Profpatsch/mailbox-org/default.nix
@@ -1,27 +1,35 @@
 { depot, pkgs, lib, ... }:
 
 let
+  mailbox-org = pkgs.haskellPackages.mkDerivation {
+    pname = "mailbox-org";
+    version = "0.1.0";
 
-  cas-serve =
-    lib.pipe ./MailboxOrg.hs [
-      (depot.users.Profpatsch.writers.writeHaskellInteractive "mailbox-org"
-        {
-          libraries = [
-            depot.users.Profpatsch.my-prelude
-            depot.users.Profpatsch.execline.exec-helpers-hs
-            depot.users.Profpatsch.arglib.netencode.haskell
-            pkgs.haskellPackages.aeson
-            pkgs.haskellPackages.http-conduit
-            pkgs.haskellPackages.aeson-better-errors
+    src = depot.users.Profpatsch.exactSource ./. [
+      ./mailbox-org.cabal
+      ./AesonQQ.hs
+      ./MailboxOrg.hs
+    ];
 
-          ];
-          ghcArgs = [ "-threaded" ];
-        })
-      (depot.users.Profpatsch.arglib.netencode.with-args {
-        BINS = depot.nix.getBins pkgs.dovecot_pigeonhole [ "sieve-test" ];
-      })
+    libraryHaskellDepends = [
+      depot.users.Profpatsch.my-prelude
+      depot.users.Profpatsch.execline.exec-helpers-hs
+      depot.users.Profpatsch.arglib.netencode.haskell
+      pkgs.haskellPackages.aeson
+      pkgs.haskellPackages.http-conduit
+      pkgs.haskellPackages.aeson-better-errors
     ];
 
+    isLibrary = false;
+    isExecutable = true;
+    license = lib.licenses.mit;
+  };
+
 
 in
-cas-serve
+lib.pipe mailbox-org [
+  (x: (depot.nix.getBins x [ "mailbox-org" ]).mailbox-org)
+  (depot.users.Profpatsch.arglib.netencode.with-args "mailbox-org" {
+    BINS = depot.nix.getBins pkgs.dovecot_pigeonhole [ "sieve-test" ];
+  })
+]