about summary refs log tree commit diff
path: root/users/Profpatsch/mailbox-org/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/mailbox-org/default.nix')
-rw-r--r--users/Profpatsch/mailbox-org/default.nix30
1 files changed, 19 insertions, 11 deletions
diff --git a/users/Profpatsch/mailbox-org/default.nix b/users/Profpatsch/mailbox-org/default.nix
index 217fd498e5..99b9d45b7d 100644
--- a/users/Profpatsch/mailbox-org/default.nix
+++ b/users/Profpatsch/mailbox-org/default.nix
@@ -2,18 +2,26 @@
 
 let
 
-  cas-serve = depot.users.Profpatsch.writers.writeHaskellInteractive "mailbox-org"
-    {
-      libraries = [
-        depot.users.Profpatsch.my-prelude
-        depot.users.Profpatsch.execline.exec-helpers-hs
-        pkgs.haskellPackages.aeson
-        pkgs.haskellPackages.http-conduit
-        pkgs.haskellPackages.aeson-better-errors
+  cas-serve =
+    lib.pipe ./MailboxOrg.hs [
+      (depot.users.Profpatsch.writers.writeHaskellInteractive "mailbox-org"
+        {
+          libraries = [
+            depot.users.Profpatsch.my-prelude
+            depot.users.Profpatsch.execline.exec-helpers-hs
+            depot.users.Profpatsch.arglib.netencode.haskell
+            pkgs.haskellPackages.aeson
+            pkgs.haskellPackages.http-conduit
+            pkgs.haskellPackages.aeson-better-errors
+
+          ];
+          ghcArgs = [ "-threaded" ];
+        })
+      (depot.users.Profpatsch.arglib.netencode.with-args {
+        BINS = depot.nix.getBins pkgs.dovecot_pigeonhole [ "sieve-test" ];
+      })
+    ];
 
-      ];
-      ghcArgs = [ "-threaded" ];
-    } ./MailboxOrg.hs;
 
 in
 cas-serve