about summary refs log tree commit diff
path: root/users/Profpatsch/ical-smolify/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/ical-smolify/default.nix')
-rw-r--r--users/Profpatsch/ical-smolify/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/users/Profpatsch/ical-smolify/default.nix b/users/Profpatsch/ical-smolify/default.nix
new file mode 100644
index 0000000000..f67d175ce3
--- /dev/null
+++ b/users/Profpatsch/ical-smolify/default.nix
@@ -0,0 +1,16 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  cas-serve = pkgs.writers.writeHaskell "ical-smolify"
+    {
+      libraries = [
+        pkgs.haskellPackages.iCalendar
+        depot.users.Profpatsch.my-prelude
+        depot.users.Profpatsch.execline.exec-helpers-hs
+
+      ];
+      ghcArgs = [ "-threaded" ];
+    } ./IcalSmolify.hs;
+
+in
+cas-serve