about summary refs log tree commit diff
path: root/users/Profpatsch/execline/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/execline/default.nix')
-rw-r--r--users/Profpatsch/execline/default.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/users/Profpatsch/execline/default.nix b/users/Profpatsch/execline/default.nix
index 752774e6ad..9b8856a9a8 100644
--- a/users/Profpatsch/execline/default.nix
+++ b/users/Profpatsch/execline/default.nix
@@ -7,6 +7,23 @@ let
     }
     (builtins.readFile ./exec_helpers.rs);
 
+  exec-helpers-hs = pkgs.haskellPackages.mkDerivation {
+    pname = "exec-helpers";
+    version = "0.1.0";
+
+    src = depot.users.Profpatsch.exactSource ./. [
+      ./exec-helpers.cabal
+      ./ExecHelpers.hs
+    ];
+
+    libraryHaskellDepends = [
+      depot.users.Profpatsch.my-prelude
+    ];
+
+    isLibrary = true;
+    license = lib.licenses.mit;
+  };
+
   print-one-env = depot.nix.writers.rustSimple
     {
       name = "print-one-env";
@@ -32,6 +49,7 @@ in
 depot.nix.readTree.drvTargets {
   inherit
     exec-helpers
+    exec-helpers-hs
     print-one-env
     ;
 }