about summary refs log tree commit diff
path: root/users/Profpatsch/execline/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'users/Profpatsch/execline/default.nix')
-rw-r--r--users/Profpatsch/execline/default.nix17
1 files changed, 1 insertions, 16 deletions
diff --git a/users/Profpatsch/execline/default.nix b/users/Profpatsch/execline/default.nix
index 51f4923e96..852fcfcfa0 100644
--- a/users/Profpatsch/execline/default.nix
+++ b/users/Profpatsch/execline/default.nix
@@ -3,22 +3,7 @@
 let
   exec-helpers = depot.users.Profpatsch.writers.rustSimpleLib {
     name = "exec-helpers";
-  } ''
-    use std::os::unix::process::CommandExt;
-    use std::ffi::OsStr;
-    use std::os::unix::ffi::OsStrExt;
-    pub fn exec_into_args<'a, I>(prog_name: &str, env_additions: I) -> !
-      where
-        I: IntoIterator<Item = (&'a [u8], &'a [u8])>,
-    {
-        let mut argv = std::env::args_os();
-        let prog = argv.nth(1).expect(&format!("{}: first argument must be an executable", prog_name));
-        let args = argv;
-        let env = env_additions.into_iter().map(|(k,v)| (OsStr::from_bytes(k), OsStr::from_bytes(v)));
-        let err = std::process::Command::new(prog).args(args).envs(env).exec();
-        panic!("{}: exec failed: {:?}", prog_name, err);
-    }
-  '';
+  } (builtins.readFile ./exec_helpers.rs);
 
 in {
   inherit