about summary refs log tree commit diff
path: root/universe/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'universe/default.nix')
-rw-r--r--universe/default.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/universe/default.nix b/universe/default.nix
deleted file mode 100644
index ff4f40d8f943..000000000000
--- a/universe/default.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-# At the time of this writing, this configuration was taken from @tazjin's
-# default.nix from his depot. I've added, changed, and removed that parts that I
-# don't need, and this is what remains.
-{ ... }@args:
-
-with builtins;
-
-let
-  fix = f: let x = f x; in x;
-
-  # Global configuration that all packages are called with.
-  config = pkgs: {
-    inherit pkgs;
-  };
-
-  readTree' = import ~/depot/nix/readTree {};
-
-  # TODO: Find a better way to expose entire monorepo without introducing
-  # "infinite recursion".
-  localPkgs = readTree: {
-    blog = readTree ./blog;
-    lisp = readTree ./lisp;
-    third_party = readTree ./third_party;
-  };
-in fix(self: {
-  config = config self;
-
-  # Expose readTree for downstream repo consumers.
-  readTree = {
-    __functor = x: (readTree' x.config);
-    config = self.config;
-  };
-}
-
-# Add local packages as structured by readTree
-// (localPkgs (readTree' (self.config // { inherit (self) lib; })))
-)