about summary refs log tree commit diff
path: root/tvix/utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/utils.nix')
-rw-r--r--tvix/utils.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/tvix/utils.nix b/tvix/utils.nix
index 5edc1dc2e856..0bb9323d684d 100644
--- a/tvix/utils.nix
+++ b/tvix/utils.nix
@@ -22,21 +22,23 @@
       (powerset features));
 
   # Filters the given source, only keeping files related to the build, preventing unnecessary rebuilds.
-  # Includes src in the root, all other .rs files, as well as Cargo.toml.
+  # Includes src in the root, all other .rs files and optionally Cargo specific files.
   # Additional files to be included can be specified in extraFileset.
   filterRustCrateSrc =
     { root # The original src
     , extraFileset ? null # Additional filesets to include (e.g. fileFilter for proto files)
+    , cargoSupport ? false
     }:
     lib.fileset.toSource {
       inherit root;
-      fileset = (lib.fileset.intersection
+      fileset = lib.fileset.intersection
         (lib.fileset.fromSource root) # We build our final fileset from the original src
         (lib.fileset.unions ([
           (root + "/src")
           (lib.fileset.fileFilter (f: f.hasExt "rs") root)
-          # We assume that every Rust crate will at a minimum have .rs files and a Cargo.toml
+        ] ++ lib.optionals cargoSupport [
           (lib.fileset.fileFilter (f: f.name == "Cargo.toml") root)
-        ] ++ lib.optional (extraFileset != null) extraFileset)));
+          (lib.fileset.maybeMissing (root + "/Cargo.lock"))
+        ] ++ lib.optional (extraFileset != null) extraFileset));
     };
 }