about summary refs log tree commit diff
path: root/tvix/tracing/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tracing/Cargo.toml')
-rw-r--r--tvix/tracing/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/tvix/tracing/Cargo.toml b/tvix/tracing/Cargo.toml
index bc9a8c3c7792..80892bf7a09f 100644
--- a/tvix/tracing/Cargo.toml
+++ b/tvix/tracing/Cargo.toml
@@ -22,6 +22,8 @@ opentelemetry-http = { version = "0.11.0", optional = true }
 tonic = { version = "0.11.0", optional = true }
 http  = { version = "0.2.11", optional = true }
 
+reqwest-tracing = { version = "0.4.8", default-features = false, optional = true }
+
 [features]
 default = []
 otlp = [
@@ -29,7 +31,8 @@ otlp = [
   "dep:opentelemetry",
   "dep:opentelemetry-otlp",
   "dep:opentelemetry_sdk",
-  "dep:opentelemetry-http"
+  "dep:opentelemetry-http",
+  "reqwest-tracing?/opentelemetry_0_22",
 ]
 tracy = [
   "dep:tracing-tracy"
@@ -38,6 +41,9 @@ tonic = [
   "dep:tonic",
   "dep:http",
 ]
+reqwest = [
+  "dep:reqwest-tracing",
+]
 
 [lints]
 workspace = true