about summary refs log tree commit diff
path: root/tvix/tools/turbofetch/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/tools/turbofetch/default.nix')
-rw-r--r--tvix/tools/turbofetch/default.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/tvix/tools/turbofetch/default.nix b/tvix/tools/turbofetch/default.nix
new file mode 100644
index 000000000000..b7b6a052d76a
--- /dev/null
+++ b/tvix/tools/turbofetch/default.nix
@@ -0,0 +1,12 @@
+{ lib, pkgs, ... }:
+
+(pkgs.callPackage ./Cargo.nix {
+  defaultCrateOverrides = pkgs.defaultCrateOverrides // {
+    ring = prev: {
+      # TODO(edef): implement CARGO_MANIFEST_LINKS in crate2nix
+      CARGO_MANIFEST_LINKS = ''ring_core_${lib.replaceStrings ["."] ["_"] prev.version}'';
+    };
+  };
+}).rootCrate.build.override {
+  runTests = true;
+}