about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix19
1 files changed, 19 insertions, 0 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
new file mode 100644
index 000000000000..4ec94cd90d9a
--- /dev/null
+++ b/tvix/store/default.nix
@@ -0,0 +1,19 @@
+{ depot, pkgs, lib, ... }:
+
+let
+  protoRoot = depot.nix.sparseTree depot.path.origSrc [
+    ./protos/castore.proto
+    ./protos/pathinfo.proto
+  ];
+in
+depot.third_party.naersk.buildPackage {
+  src = depot.third_party.gitignoreSource ./.;
+  # see https://github.com/nix-community/naersk/issues/169
+  root = depot.nix.sparseTree ./. [ ./Cargo.lock ./Cargo.toml ];
+
+  nativeBuildInputs = [ pkgs.protobuf ];
+
+  PROTO_ROOT = protoRoot;
+
+  doCheck = true;
+}