about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix36
1 files changed, 1 insertions, 35 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 65289cacc87c..3d873a097ec4 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -1,39 +1,5 @@
-{ depot, pkgs, ... }:
+{ depot, ... }:
 
-let
-  protoRoot = depot.nix.sparseTree depot.path.origSrc [
-    ./protos/castore.proto
-    ./protos/pathinfo.proto
-    ./protos/rpc_blobstore.proto
-    ./protos/rpc_directory.proto
-    ./protos/rpc_pathinfo.proto
-  ];
-
-  protobufDep = prev: (prev.nativeBuildInputs or [ ]) ++ [ pkgs.protobuf ];
-in
 depot.tvix.crates.workspaceMembers.tvix-store-bin.build.override {
-  # Ensure protobuf dependencies are available.
-  # TODO: figure out a way to embed this directly in the //tvix
-  # crate2nix config.
-  crateOverrides = {
-    prost-build = prev: {
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tonic-reflection = prev: {
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tvix-store = prev: {
-      PROTO_ROOT = protoRoot;
-      nativeBuildInputs = protobufDep prev;
-    };
-
-    tvix-store-bin = prev: {
-      PROTO_ROOT = protoRoot;
-      nativeBuildInputs = protobufDep prev;
-    };
-  };
-
   runTests = true;
 }