about summary refs log tree commit diff
path: root/tvix/store/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/default.nix')
-rw-r--r--tvix/store/default.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/tvix/store/default.nix b/tvix/store/default.nix
index 0372047e94..35d2a22bb2 100644
--- a/tvix/store/default.nix
+++ b/tvix/store/default.nix
@@ -25,7 +25,8 @@ in
 (depot.tvix.crates.workspaceMembers.tvix-store.build.override {
   runTests = true;
   # virtiofs feature currently fails to build on Darwin.
-  features = if pkgs.stdenv.isDarwin then [ "fuse" "tonic-reflection" ] else [ "default" ];
+  # we however can ship it for non-darwin.
+  features = if pkgs.stdenv.isDarwin then [ "default" ] else [ "default" "virtiofs" ];
 }).overrideAttrs (_: {
   meta.ci.extraSteps = {
     import-docs = (mkImportCheck "tvix/store/docs" ./docs);