about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml60
1 files changed, 30 insertions, 30 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index ffe05b4a37e9..552ef6f9165a 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -4,48 +4,48 @@ version = "0.1.0"
 edition = "2021"
 
 [dependencies]
-anyhow = "1.0.68"
-async-compression = { version = "0.4.9", features = ["tokio", "bzip2", "gzip", "xz", "zstd"]}
+anyhow = "1.0.86"
+async-compression = { version = "0.4.12", features = ["tokio", "bzip2", "gzip", "xz", "zstd"]}
 async-stream = "0.3.5"
-blake3 = { version = "1.3.1", features = ["rayon", "std"] }
-bstr = "1.6.0"
-bytes = "1.4.0"
-clap = { version = "4.0", features = ["derive", "env"] }
+blake3 = { version = "1.5.4", features = ["rayon", "std"] }
+bstr = "1.10.0"
+bytes = "1.7.1"
+clap = { version = "4.5", features = ["derive", "env"] }
 count-write = "0.1.0"
 data-encoding = "2.6.0"
 futures = "0.3.30"
-lazy_static = "1.4.0"
+lazy_static = "1.5.0"
 nix-compat = { path = "../nix-compat", features = ["async"] }
-pin-project-lite = "0.2.13"
+pin-project-lite = "0.2.14"
 prost = "0.13.1"
-serde = { version = "1.0.197", features = [ "derive" ] }
+serde = { version = "1.0.209", features = [ "derive" ] }
 serde_json = "1.0"
-serde_with = "3.7.0"
+serde_with = "3.9.0"
 serde_qs = "0.12.0"
-sha2 = "0.10.6"
+sha2 = "0.10.8"
 sled = { version = "0.34.7" }
-thiserror = "1.0.38"
-tokio = { version = "1.32.0", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
-tokio-listener = { version = "0.4.2", features = [ "clap", "multi-listener", "sd_listen", "tonic012" ] }
-tokio-stream = { version = "0.1.14", features = ["fs"] }
-tokio-util = { version = "0.7.9", features = ["io", "io-util", "compat"] }
-tonic = { version = "0.12.0", features = ["tls", "tls-roots"] }
+thiserror = "1.0.63"
+tokio = { version = "1.39.3", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
+tokio-listener = { version = "0.4.3", features = [ "clap", "multi-listener", "sd_listen", "tonic012" ] }
+tokio-stream = { version = "0.1.15", features = ["fs"] }
+tokio-util = { version = "0.7.11", features = ["io", "io-util", "compat"] }
+tonic = { version = "0.12.2", features = ["tls", "tls-roots"] }
 tower = "0.4.13"
-tower-http = { version = "0.5.0", features = ["trace"] }
+tower-http = { version = "0.5.2", features = ["trace"] }
 tvix-castore = { path = "../castore" }
-url = "2.4.0"
-walkdir = "2.4.0"
-reqwest = { version = "0.12.0", features = ["rustls-tls-native-roots", "stream"], default-features = false }
-reqwest-middleware = "0.3.0"
-lru = "0.12.3"
-parking_lot = "0.12.2"
+url = "2.5.2"
+walkdir = "2.5.0"
+reqwest = { version = "0.12.7", features = ["rustls-tls-native-roots", "stream"], default-features = false }
+reqwest-middleware = "0.3.3"
+lru = "0.12.4"
+parking_lot = "0.12.3"
 tvix-tracing = { path = "../tracing", features = ["tonic", "reqwest"] }
 tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
 hyper-util = "0.1.7"
-toml = { version = "0.8.15", optional = true }
-tonic-health = { version = "0.12.1", default-features = false }
-redb = "2.1.1"
+toml = { version = "0.8.19", optional = true }
+tonic-health = { version = "0.12.2", default-features = false }
+redb = "2.1.2"
 mimalloc = "0.1.43"
 
 [dependencies.tonic-reflection]
@@ -60,13 +60,13 @@ rev = "1818355a5373a5bc2c84287e3a4e3807154ac8ef"
 
 [build-dependencies]
 prost-build = "0.13.1"
-tonic-build = "0.12.0"
+tonic-build = "0.12.2"
 
 [dev-dependencies]
-async-process = "2.1.0"
+async-process = "2.2.4"
 rstest = "0.19.0"
 rstest_reuse = "0.6.0"
-tempfile = "3.3.0"
+tempfile = "3.12.0"
 tokio-retry = "0.3.0"
 
 [features]