about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 8063a0e874c3..f1d88ba085ea 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -17,7 +17,7 @@ futures = "0.3.30"
 lazy_static = "1.4.0"
 nix-compat = { path = "../nix-compat", features = ["async"] }
 pin-project-lite = "0.2.13"
-prost = "0.12.1"
+prost = "0.13.1"
 serde = { version = "1.0.197", features = [ "derive" ] }
 serde_json = "1.0"
 serde_with = "3.7.0"
@@ -26,34 +26,35 @@ sha2 = "0.10.6"
 sled = { version = "0.34.7" }
 thiserror = "1.0.38"
 tokio = { version = "1.32.0", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
-tokio-listener = { version = "0.4.2", features = [ "clap", "multi-listener", "sd_listen", "tonic011" ] }
+tokio-listener = { version = "0.4.2", features = [ "clap", "multi-listener", "sd_listen", "tonic012" ] }
 tokio-stream = { version = "0.1.14", features = ["fs"] }
 tokio-util = { version = "0.7.9", features = ["io", "io-util", "compat"] }
-tonic = { version = "0.11.0", features = ["tls", "tls-roots"] }
+tonic = { version = "0.12.0", features = ["tls", "tls-roots"] }
 tower = "0.4.13"
-tower-http = { version = "0.4.4", features = ["trace"] }
+tower-http = { version = "0.5.0", features = ["trace"] }
 tvix-castore = { path = "../castore" }
 url = "2.4.0"
 walkdir = "2.4.0"
-reqwest = { version = "0.11.22", features = ["rustls-tls-native-roots", "stream"], default-features = false }
-reqwest-middleware = "0.2.5"
+reqwest = { version = "0.12.0", features = ["rustls-tls-native-roots", "stream"], default-features = false }
+reqwest-middleware = "0.3.0"
 lru = "0.12.3"
 parking_lot = "0.12.2"
 tvix-tracing = { path = "../tracing", features = ["tonic", "reqwest"] }
 tracing = "0.1.40"
 tracing-indicatif = "0.3.6"
+hyper-util = "0.1.6"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.11.0"
+version = "0.12.0"
 
 [dependencies.bigtable_rs]
 optional = true
 version = "0.2.10"
 
 [build-dependencies]
-prost-build = "0.12.1"
-tonic-build = "0.11.0"
+prost-build = "0.13.1"
+tonic-build = "0.12.0"
 
 [dev-dependencies]
 async-process = "2.1.0"