about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml12
1 files changed, 12 insertions, 0 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 5cae4e0dfc..90672b6d03 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -15,9 +15,21 @@ tokio = { version = "1.23.0", features = ["rt-multi-thread"] }
 tokio-stream = "0.1.11"
 tonic = "0.8.2"
 
+[dependencies.tonic-reflection]
+optional = true
+version = "0.5.0"
+
 [build-dependencies]
 prost-build = "0.11.2"
 tonic-build = "0.8.2"
 
 [dev-dependencies]
 test-case = "2.2.2"
+
+[features]
+default = [
+  "reflection"
+]
+reflection = [
+  "tonic-reflection"
+]