about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml11
1 files changed, 10 insertions, 1 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index a88bdefd7a..3b2765f992 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -30,10 +30,18 @@ bytes = "1.4.0"
 smol_str = "0.2.0"
 serde_json = "1.0"
 
+[dependencies.fuser]
+optional = true
+version = "0.12.0"
+
 [dependencies.tonic-reflection]
 optional = true
 version = "0.5.0"
 
+[dependencies.libc]
+optional = true
+version = "0.2.144"
+
 [build-dependencies]
 prost-build = "0.11.2"
 tonic-build = "0.8.2"
@@ -44,5 +52,6 @@ tempfile = "3.3.0"
 tonic-mock = { git = "https://github.com/brainrake/tonic-mock", branch = "bump-dependencies" }
 
 [features]
-default = ["reflection"]
+default = ["fuse", "reflection"]
+fuse = ["dep:fuser", "dep:libc"]
 reflection = ["tonic-reflection"]