about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml14
1 files changed, 7 insertions, 7 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 2b2a981596..e4ebfc9a0f 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -16,14 +16,14 @@ lazy_static = "1.4.0"
 nix-compat = { path = "../nix-compat" }
 parking_lot = "0.12.1"
 pin-project-lite = "0.2.13"
-prost = "0.11.2"
+prost = "0.12.1"
 sha2 = "0.10.6"
 sled = { version = "0.34.7", features = ["compression"] }
 thiserror = "1.0.38"
 tokio-stream = { version = "0.1.14", features = ["fs"] }
-tokio-util = { version = "0.7.8", features = ["io", "io-util"] }
-tokio = { version = "1.28.0", features = ["fs", "net", "rt-multi-thread", "signal"] }
-tonic = "0.8.2"
+tokio-util = { version = "0.7.9", features = ["io", "io-util"] }
+tokio = { version = "1.32.0", features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
+tonic = "0.10.2"
 tower = "0.4.13"
 tracing = "0.1.37"
 tracing-subscriber = { version = "0.3.16", features = ["json"] }
@@ -64,15 +64,15 @@ version = "0.2.1"
 
 [dependencies.tonic-reflection]
 optional = true
-version = "0.5.0"
+version = "0.10.2"
 
 [dependencies.libc]
 optional = true
 version = "0.2.144"
 
 [build-dependencies]
-prost-build = "0.11.2"
-tonic-build = "0.8.2"
+prost-build = "0.12.1"
+tonic-build = "0.10.2"
 
 [dev-dependencies]
 test-case = "2.2.2"