about summary refs log tree commit diff
path: root/tvix/store/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/store/Cargo.toml')
-rw-r--r--tvix/store/Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/tvix/store/Cargo.toml b/tvix/store/Cargo.toml
index 81f9d7e75b..a2e143de70 100644
--- a/tvix/store/Cargo.toml
+++ b/tvix/store/Cargo.toml
@@ -7,28 +7,29 @@ edition = "2021"
 anyhow = "1.0.68"
 async-stream = "0.3.5"
 blake3 = { version = "1.3.1", features = ["rayon", "std"] }
+bytes = "1.4.0"
 clap = { version = "4.0", features = ["derive", "env"] }
 count-write = "0.1.0"
 data-encoding = "2.3.3"
+futures = "0.3.28"
 lazy_static = "1.4.0"
 nix-compat = { path = "../nix-compat" }
 parking_lot = "0.12.1"
+pin-project-lite = "0.2.13"
 prost = "0.11.2"
 sha2 = "0.10.6"
 sled = { version = "0.34.7", features = ["compression"] }
 thiserror = "1.0.38"
 tokio-stream = { version = "0.1.14", features = ["fs"] }
+tokio-util = { version = "0.7.8", features = ["io", "io-util"] }
 tokio = { version = "1.28.0", features = ["fs", "net", "rt-multi-thread", "signal"] }
 tonic = "0.8.2"
+tower = "0.4.13"
 tracing = "0.1.37"
 tracing-subscriber = { version = "0.3.16", features = ["json"] }
-walkdir = "2.4.0"
-tokio-util = { version = "0.7.8", features = ["io", "io-util"] }
-tower = "0.4.13"
-futures = "0.3.28"
-bytes = "1.4.0"
+tvix-castore = { path = "../castore" }
 url = "2.4.0"
-pin-project-lite = "0.2.13"
+walkdir = "2.4.0"
 
 [dependencies.fuse-backend-rs]
 optional = true