about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/shell.nix')
-rw-r--r--tvix/shell.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
new file mode 100644
index 0000000000..600d96d76d
--- /dev/null
+++ b/tvix/shell.nix
@@ -0,0 +1,10 @@
+let
+  depot = (import ./.. {});
+  pkgs = depot.third_party.nixpkgs;
+
+in pkgs.mkShell {
+  buildInputs = [
+    pkgs.rustup
+    pkgs.rust-analyzer
+  ];
+}