about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/shell.nix')
-rw-r--r--tvix/shell.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
index d6b4bb7d3458..0d5e2f27b5df 100644
--- a/tvix/shell.nix
+++ b/tvix/shell.nix
@@ -48,6 +48,7 @@ pkgs.mkShell {
     pkgs.mdbook-plantuml
     pkgs.nix_2_3 # b/313
     pkgs.pkg-config
+    pkgs.runc
     pkgs.rust-analyzer
     pkgs.rustc
     pkgs.rustfmt
@@ -66,6 +67,7 @@ pkgs.mkShell {
   # should also benchmark with a more static nixpkgs checkout, so nixpkgs
   # refactorings are not observed as eval perf changes.
   shellHook = ''
+    export TVIX_BUILD_SANDBOX_SHELL=${pkgs.busybox-sandbox-shell}/bin/busybox
     export TVIX_BENCH_NIX_PATH=nixpkgs=${pkgs.path}
   '';
 }