about summary refs log tree commit diff
path: root/tvix/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/shell.nix')
-rw-r--r--tvix/shell.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/tvix/shell.nix b/tvix/shell.nix
index eae0931bfd09..947cda269b2f 100644
--- a/tvix/shell.nix
+++ b/tvix/shell.nix
@@ -16,6 +16,19 @@
             ./nixpkgs/cbtemulator-uds.patch
           ];
         });
+
+        # macFUSE bump containing fix for https://github.com/osxfuse/osxfuse/issues/974
+        # https://github.com/NixOS/nixpkgs/pull/320197
+        fuse =
+          if super.stdenv.isDarwin then
+            super.fuse.overrideAttrs
+              (old: rec {
+                version = "4.8.0";
+                src = super.fetchurl {
+                  url = "https://github.com/osxfuse/osxfuse/releases/download/macfuse-${version}/macfuse-${version}.dmg";
+                  hash = "sha256-ucTzO2qdN4QkowMVvC3+4pjEVjbwMsB0xFk+bvQxwtQ=";
+                };
+              }) else super.fuse;
       })
     ];
   })