about summary refs log tree commit diff
path: root/tvix/nix-daemon/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nix-daemon/Cargo.toml')
-rw-r--r--tvix/nix-daemon/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/tvix/nix-daemon/Cargo.toml b/tvix/nix-daemon/Cargo.toml
new file mode 100644
index 000000000000..39b34019b424
--- /dev/null
+++ b/tvix/nix-daemon/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "nix-daemon"
+version = "0.1.0"
+edition = "2021"
+
+[dependencies]
+async-trait = "0.1.83"
+clap = { workspace = true, features = ["derive", "env"] }
+futures = { workspace = true }
+mimalloc = { workspace = true }
+nix-compat = { path = "../nix-compat" }
+tvix-castore = { path = "../castore" }
+tvix-store = { path = "../store" }
+tvix-tracing = { path = "../tracing" }
+tokio = { workspace = true, features = ["fs", "macros", "net", "rt", "rt-multi-thread", "signal"] }
+tokio-listener = { workspace = true }
+tracing = { workspace = true }
+
+[lints]
+workspace = true
+
+[features]
+default = ["otlp"]
+otlp = ["tvix-tracing/otlp"]
\ No newline at end of file