about summary refs log tree commit diff
path: root/tvix/nix-compat/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nix-compat/Cargo.toml')
-rw-r--r--tvix/nix-compat/Cargo.toml8
1 files changed, 7 insertions, 1 deletions
diff --git a/tvix/nix-compat/Cargo.toml b/tvix/nix-compat/Cargo.toml
index 9f43bb24efcc..87e9b1e6760c 100644
--- a/tvix/nix-compat/Cargo.toml
+++ b/tvix/nix-compat/Cargo.toml
@@ -8,9 +8,10 @@ edition = "2021"
 async = ["tokio"]
 # code emitting low-level packets used in the daemon protocol.
 wire = ["tokio", "pin-project-lite", "bytes"]
+test = []
 
 # Enable all features by default.
-default = ["async", "wire"]
+default = ["async", "wire", "nix-compat-derive"]
 
 [dependencies]
 bitflags = "2.4.1"
@@ -33,6 +34,11 @@ tracing = "0.1.37"
 optional = true
 version = "1.6.1"
 
+[dependencies.nix-compat-derive]
+path = "../nix-compat-derive"
+optional = true
+default-features = false
+
 [dependencies.tokio]
 optional = true
 version = "1.32.0"