about summary refs log tree commit diff
path: root/tvix/nar-bridge/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/nar-bridge/Cargo.toml')
-rw-r--r--tvix/nar-bridge/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/tvix/nar-bridge/Cargo.toml b/tvix/nar-bridge/Cargo.toml
index 79d65f77c1d3..e2d50befb68e 100644
--- a/tvix/nar-bridge/Cargo.toml
+++ b/tvix/nar-bridge/Cargo.toml
@@ -16,11 +16,13 @@ futures = { workspace = true }
 itertools = { workspace = true }
 prost = { workspace = true }
 nix-compat = { path = "../nix-compat", features = ["async"] }
+opentelemetry = { workspace = true }
 thiserror = { workspace = true }
 tokio = { workspace = true }
 tokio-listener = { workspace = true, features = ["axum07", "clap", "multi-listener", "sd_listen"] }
 tokio-util = { workspace = true, features = ["io", "io-util", "compat"] }
 tonic = { workspace = true, features = ["tls", "tls-roots"] }
+tower-otel-http-metrics = { workspace = true, optional = true }
 tvix-castore = { path = "../castore" }
 tvix-store = { path = "../store" }
 tvix-tracing = { path = "../tracing", features = ["tonic", "axum"] }
@@ -38,7 +40,7 @@ tonic-build = { workspace = true }
 
 [features]
 default = ["otlp"]
-otlp = ["tvix-tracing/otlp"]
+otlp = ["tvix-tracing/otlp", "tower-otel-http-metrics"]
 xp-store-composition-cli = ["tvix-store/xp-composition-cli"]
 
 [dev-dependencies]