about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/lib.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/lib.nix37
1 files changed, 20 insertions, 17 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/lib.nix b/tvix/eval/src/tests/tvix_tests/lib.nix
index 028a538314..ab509bc85f 100644
--- a/tvix/eval/src/tests/tvix_tests/lib.nix
+++ b/tvix/eval/src/tests/tvix_tests/lib.nix
@@ -3,7 +3,7 @@ with builtins;
 rec {
 
   fold = op: nul: list:
-    if list == []
+    if list == [ ]
     then nul
     else op (head list) (fold op nul (tail list));
 
@@ -14,23 +14,25 @@ rec {
 
   flatten = x:
     if isList x
-    then fold (x: y: (flatten x) ++ y) [] x
-    else [x];
+    then fold (x: y: (flatten x) ++ y) [ ] x
+    else [ x ];
 
   sum = foldl' (x: y: add x y) 0;
 
   hasSuffix = ext: fileName:
-    let lenFileName = stringLength fileName;
-        lenExt = stringLength ext;
-    in !(lessThan lenFileName lenExt) &&
-       substring (sub lenFileName lenExt) lenFileName fileName == ext;
+    let
+      lenFileName = stringLength fileName;
+      lenExt = stringLength ext;
+    in
+    !(lessThan lenFileName lenExt) &&
+    substring (sub lenFileName lenExt) lenFileName fileName == ext;
 
   # Split a list at the given position.
   splitAt = pos: list:
-    if pos == 0 then {first = []; second = list;} else
-    if list == [] then {first = []; second = [];} else
+    if pos == 0 then { first = [ ]; second = list; } else
+    if list == [ ] then { first = [ ]; second = [ ]; } else
     let res = splitAt (sub pos 1) (tail list);
-    in {first = [(head list)] ++ res.first; second = res.second;};
+    in { first = [ (head list) ] ++ res.first; second = res.second; };
 
   # Stable merge sort.
   sortBy = comp: list:
@@ -40,14 +42,15 @@ rec {
         split = splitAt (div (length list) 2) list;
         first = sortBy comp split.first;
         second = sortBy comp split.second;
-      in mergeLists comp first second
+      in
+      mergeLists comp first second
     else list;
 
   mergeLists = comp: list1: list2:
-    if list1 == [] then list2 else
-    if list2 == [] then list1 else
-    if comp (head list2) (head list1) then [(head list2)] ++ mergeLists comp list1 (tail list2) else
-    [(head list1)] ++ mergeLists comp (tail list1) list2;
+    if list1 == [ ] then list2 else
+    if list2 == [ ] then list1 else
+    if comp (head list2) (head list1) then [ (head list2) ] ++ mergeLists comp list1 (tail list2) else
+    [ (head list1) ] ++ mergeLists comp (tail list1) list2;
 
   id = x: x;
 
@@ -55,7 +58,7 @@ rec {
 
   range = first: last:
     if first > last
-      then []
-      else genList (n: first + n) (last - first + 1);
+    then [ ]
+    else genList (n: first + n) (last - first + 1);
 
 }