about summary refs log tree commit diff
path: root/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix')
-rw-r--r--tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix13
1 files changed, 7 insertions, 6 deletions
diff --git a/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix b/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
index 89888fd561..551db72cb0 100644
--- a/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
+++ b/tvix/eval/src/tests/tvix_tests/eval-okay-listtoattrs.nix
@@ -1,15 +1,16 @@
 with builtins;
 let
   fold = op: nul: list:
-    if list == []
+    if list == [ ]
     then nul
     else op (head list) (fold op nul (tail list));
   concat =
     fold (x: y: x + y) "";
-  asi = name: value : { inherit name value; };
-  list = [ ( asi "a" "A" ) ( asi "b" "B" ) ];
+  asi = name: value: { inherit name value; };
+  list = [ (asi "a" "A") (asi "b" "B") ];
   a = builtins.listToAttrs list;
-  b = builtins.listToAttrs ( list ++ list );
-  r = builtins.listToAttrs [ (asi "result" [ a b ]) ( asi "throw" (throw "this should not be thrown")) ];
+  b = builtins.listToAttrs (list ++ list);
+  r = builtins.listToAttrs [ (asi "result" [ a b ]) (asi "throw" (throw "this should not be thrown")) ];
   x = builtins.listToAttrs [ (asi "foo" "bar") (asi "foo" "bla") ];
-in concat (map (x: x.a) r.result) + x.foo
+in
+concat (map (x: x.a) r.result) + x.foo