about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 5ccfa63283..a8d93ca0ec 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -21,6 +21,8 @@ tabwriter = "1.2"
 rowan = "*" # pinned by rnix
 codemap = "0.1.3"
 codemap-diagnostic = "0.1.1"
+proptest = { version = "1.0.0", default_features = false, features = ["std", "alloc", "break-dead-code", "tempfile"], optional = true }
+test-strategy = { version = "0.2.1", optional = true }
 
 # rnix has not been released in a while (as of 2022-09-01), we will
 # use it from git.
@@ -36,7 +38,7 @@ itertools = "0.10.3"
 tempdir = "0.3.7"
 
 [features]
-default = [ "repl" ]
+default = [ "repl", "arbitrary" ]
 
 # Enables running the Nix language test suite from the original C++
 # Nix implementation (at version 2.3) against Tvix.
@@ -45,6 +47,9 @@ nix_tests = []
 # Enables building the binary (tvix-eval REPL)
 repl = [ "dep:rustyline" ]
 
+# Enables Arbitrary impls for internal types (required to run tests)
+arbitrary = [ "proptest", "test-strategy" ]
+
 [[bench]]
 name = "eval"
 harness = false