about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml28
1 files changed, 14 insertions, 14 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 364c97d82345..bb6b04bb6ca5 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -8,25 +8,25 @@ name = "tvix_eval"
 
 [dependencies]
 builtin-macros = { path = "./builtin-macros", package = "tvix-eval-builtin-macros" }
-bytes = "1.4.0"
-bstr = { version = "1.8.0", features = ["serde"] }
+bytes = "1.7.1"
+bstr = { version = "1.10.0", features = ["serde"] }
 codemap = "0.1.3"
-codemap-diagnostic = "0.1.1"
+codemap-diagnostic = "0.1.2"
 dirs = "4.0.0"
 genawaiter = { version = "0.99.1", default-features = false }
-itertools = "0.12.0"
-lazy_static = "1.4.0"
+itertools = "0.12.1"
+lazy_static = "1.5.0"
 lexical-core = { version = "0.8.5", features = ["format", "parse-floats"] }
-os_str_bytes = { version = "6.3", features = ["conversions"] }
+os_str_bytes = { version = "6.6", features = ["conversions"] }
 path-clean = "0.1"
-proptest = { version = "1.3.0", default-features = false, features = ["std", "alloc", "tempfile"], optional = true }
-regex = "1.6.0"
+proptest = { version = "1.5.0", default-features = false, features = ["std", "alloc", "tempfile"], optional = true }
+regex = "1.10.6"
 rnix = "0.11.0"
 rowan = "*" # pinned by rnix
 serde = { version = "1.0", features = [ "rc", "derive" ] }
 serde_json = "1.0"
-smol_str = "0.2.0"
-tabwriter = "1.2"
+smol_str = "0.2.2"
+tabwriter = "1.4"
 test-strategy = { version = "0.2.1", optional = true }
 toml = "0.6.0"
 sha2 = "0.10.8"
@@ -35,15 +35,15 @@ md-5 = "0.10.6"
 data-encoding = "2.6.0"
 rustc-hash = "2.0.0"
 nohash-hasher = "0.2.0"
-vu128 = "1.0.0"
+vu128 = "1.1.0"
 
 [dev-dependencies]
 criterion = "0.5"
-itertools = "0.12.0"
+itertools = "0.12.1"
 mimalloc = "0.1.43"
-pretty_assertions = "1.2.1"
+pretty_assertions = "1.4.0"
 rstest = "0.19.0"
-tempfile = "3.3.0"
+tempfile = "3.12.0"
 
 [features]
 default = ["impure", "arbitrary", "nix_tests"]