about summary refs log tree commit diff
path: root/tvix/eval/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/eval/Cargo.toml')
-rw-r--r--tvix/eval/Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/tvix/eval/Cargo.toml b/tvix/eval/Cargo.toml
index 836b5deed1..b0ccabed2e 100644
--- a/tvix/eval/Cargo.toml
+++ b/tvix/eval/Cargo.toml
@@ -11,6 +11,7 @@ smol_str = "0.1"
 rustyline = "10.0.0"
 dirs = "4.0.0"
 path-clean = "0.1"
+tabwriter = { version = "1.2", optional = true }
 
 [dev-dependencies]
 criterion = "0.3.6"
@@ -21,6 +22,9 @@ test-generator = "0.3.0"
 # Nix implementation (at version 2.3) against Tvix.
 nix_tests = []
 
+# Enables printing compiled code and tracing the stack state at runtime.
+disassembler = ["dep:tabwriter"]
+
 [[bench]]
 name = "eval"
 harness = false