about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index e36883b471..4abf27f463 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -58,6 +58,16 @@ in
     ${depot.tools.depotfmt}/bin/depotfmt Cargo.nix
   '';
 
+  # Provide the Tvix logo in both .webp and .png format.
+  logo = pkgs.runCommand "logo"
+    {
+      nativeBuildInputs = [ pkgs.imagemagick ];
+    } ''
+    mkdir -p $out
+    cp ${./logo.webp} $out/logo.webp
+    convert $out/logo.webp $out/logo.png
+  '';
+
   # Provide a shell for the combined dependencies of all Tvix Rust
   # projects. Note that as this is manually maintained it may be
   # lacking something, but it is required for some people's workflows.