about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 7225bfb89e..23ce0592ce 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -7,4 +7,24 @@
     inherit pkgs;
     nixpkgs = pkgs.path;
   };
+
+  # Provide a shell for the combined dependencies of all Tvix Rust
+  # projects. Note that as this is manually maintained it may be
+  # lacking something, but it is required for some people's workflows.
+  #
+  # This shell can be entered with e.g. `mg shell //tvix:shell`.
+  shell = pkgs.mkShell {
+    name = "tvix-rust-dev-env";
+    packages = [
+      pkgs.buf-language-server
+      pkgs.cargo
+      pkgs.clippy
+      pkgs.rust-analyzer
+      pkgs.rustc
+      pkgs.rustfmt
+      pkgs.protobuf
+    ];
+  };
+
+  meta.ci.targets = [ "shell" ];
 }