about summary refs log tree commit diff
path: root/tvix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tvix/default.nix')
-rw-r--r--tvix/default.nix10
1 files changed, 9 insertions, 1 deletions
diff --git a/tvix/default.nix b/tvix/default.nix
index 66d4a79d99..e36883b471 100644
--- a/tvix/default.nix
+++ b/tvix/default.nix
@@ -79,6 +79,14 @@ in
     ];
   };
 
+  # Builds and tests the code in store/protos.
+  store-protos-go = pkgs.buildGoModule {
+    name = "store-golang";
+    src = depot.third_party.gitignoreSource ./store/protos;
+
+    vendorHash = "sha256-7xfXBBU3xJz7ifjk7Owm/byTfCQ8oaZtqXzBKhLqo00=";
+  };
+
   # Build the Rust documentation for publishing on docs.tvix.dev.
   rust-docs = pkgs.stdenv.mkDerivation {
     inherit cargoDeps;
@@ -103,5 +111,5 @@ in
     '';
   };
 
-  meta.ci.targets = [ "shell" "rust-docs" ];
+  meta.ci.targets = [ "store-protos-go" "shell" "rust-docs" ];
 }